Месяц: Апрель 2020

Загрузка данных в 1с из Excel

Загрузка данных в 1с из Excel применяется для организации заполнения базы данных 1с информацией. Ниже представлен код обработки позволяющий загрузить в справочник данные с листа Excel. Код рабочий предложен в качестве подсказки всем заинтересованным. КонецПроцедуры &НаКлиентеПроцедура ЗагрузитьНоменклатуру(Команда)НачатьПомещениеФайла(Новый ОписаниеОповещения(“ПослеВыбораФайла”, ЭтотОбъект));КонецПроцедуры &НаКлиентеПроцедура ПослеВыбораФайла(Результат, Адрес, ВыбранноеИмяФайла, ДопПараметры) ЭкспортЕсли Не ПустаяСтрока(ВыбранноеИмяФайла) ТогдаЗагрузитьНоменклатуруНаСервере(ВыбранноеИмяФайла);КонецЕсли;КонецПроцедуры

Роли в 1с : Предприятии

Роли в 1с : Предприятии позволяют настроить права доступа к различным объектам. Роли в системе “1С: Предприятие” определяет полномочия пользователя на работу с информацией, которая обрабатывается в системе. Совокупность предоставляемых пользователю полномочий определяет, как правило, кругом его обязанностей. Операция назначения ролей решает две задачи: Ограничивается круг пользователей имеющих доступ к…

Калькулятор на 1с Предприятии

калькулятор на 1с : Предприятии 8. Создадим собственный простейший калькулятор на 1с. 1с : Предприятие 8 имеет встроенный калькулятор. Всем, кто занимается программированием известны классические задачи по программировании. Одной из классических задач по объектно-ориентированному программированию является калькулятор. Начинающим обучающим очень часто задают данную задачу. Наша команда решила сделать калькулятор на…

Командный интерфейс 1с

Командный интерфейс 1с — это основное средство навигации пользователя по функциональности конфигурации. В системе 1С:Предприятие он строится на основе подсистем. Разработчик должен создать в конфигурации иерархию подсистем, отражающую для пользователя структуру функциональности прикладного решения. Все прикладные объекты конфигурации (справочники, документы, отчеты и т. д.) привязываются разработчиком конфигурации к подсистемам. То есть иерархия подсистем должна отражать структуру функциональности именно так, как она будет…

Роли и подсистемы

Роли и подсистемы позволяют настроить интерфейс приложения и настроить права доступа. Роли в системе «1С:Предприятие» определяют полномочия пользователей на доступ к информации. Совокупность предоставляемых пользователю полномочий определяет, как правило, кругом его обязанностей. Назначение ролей решает следующие задачи: Ограничение круга пользователей имеющих доступ к определенной информации; Запрет выполнения определенных действий, что…

Свойства объекта конфигурации

Свойства объекта конфигурации 1с позволяют настраивать объекты согласно требованиям заказчика. Каждый объект конфигурации обладает уникальным набором свойств. Этот набор свойств определяется на уровне системы. То есть изменять набор нельзя на уровни пользователя конфигурации. Также, набор свойств объекта конфигурации определяется в основном его назначением в системе 1С: Предприятие. Главным свойством любого…

Объекты конфигурации 1с. Объекты

Объекты определяют возможности конфигурации 1с. Структура прикладного решения (конфигурации) определяется составом объектов конфигурации и взаимосвязями между ними. Под объектами конфигурации понимаются средства 1С: Предприятия, предназначенные для отражения реальных объектов и явлений предметной области, например, справочник «Контрагенты», документ «Счет-фактура» и т.д. Разработчик может создавать объекты, не имеющие явного физического воплощения в…

Объекты конфигурации 1с. Введение

Объекты конфигурации 1с описывают прикладное решение. Введение При разработке прикладной задачи разработчик не обращается к базе данных напрямую, он изолирован от низкоуровневого программирования. Программист взаимодействует с платформой «1С: Предприятие». Он выполняет следующие действия: описывает структуры данных в конфигураторе; 2. манипулирует данными с помощью объектов встроенного языка; 3. составляет запросы к…

Платформа и конфигурация 1с

Платформа и конфигурация 1с составные элементы системы 1с : Предприятие. Система программ «1С: Предприятие 8.3» включает в себя платформу и прикладные решения, разработанные на ее основе, для автоматизации деятельности организаций и частных лиц. Конфигурация 1с разрабатывается для конкретной области деятельности. Например бухгалтерский учет организации. Объекты конфигурации описывают данную предметную область. При этом свойства…