Записки программиста 1с

Циклы в 1с

Циклы в 1с используются для повторяющего(циклического) выполнения заданного программного кода. Они выполняются или пока не выполнятся определенные условия.

Циклы в 1с : Предприятие 8

В 1с имеется три вида циклов:

Циклы в 1с
Операторы цикла в 1с

Цикл Для в 1с

Этот оператор циклически выполняет программный код до тех пор, пока значение переменной не превысит заданных граничных условий. Синтаксис:

Для Имяпеременной = Выражение1 По Выражение2 Цикл
… // программный код
[Продолжить;]
… // программный код
[Прервать;]
… // программный код
КонецЦикла;

 Программный код внутри данной языковой конструкции будет циклически выполняться до тех пор, пока переменная ИмяПеременной больше либо равно Выражение1, но меньше либо равно Выражение2.
Команда Продолжить, останавливает выполнение цикла на данном этапе. Она будет исполнена на следующем шаге, т. е. операторы, находящиеся ниже команды Продолжить, выполнены не будут.

Цикл Для каждого в 1с

Цикл Для каждого используется для обхода или перебора коллекции значений( Например массива). Синтаксис:

Для каждого Переменная из КоллекцияЗначений Цикл
… // программный код
[Продолжить;]
… // программный код
[Прервать;]
… // программный код
КонецЦикла;

В этой языковой конструкции осуществляется циклический обход заданной коллекции значений (подборка данных, строки таблицы, какой-то список и т. д.).
Переменная является счетчиком цикла.

Цикл Пока в 1с

Данный оператор применим для циклического повторения операторов, находящихся внутри языковой конструкции Цикл…КонецЦикла. Цикл выполняется, пока логическое выражение равно Истина. Синтаксис:

Пока Выражение Цикл
... // программный код
[Продолжить;]
... // программный код
[Прервать;]
... // программный код
КонецЦикла;

Программный код внутри данной языковой конструкции будет циклически выполняться до тех пор, пока Выражение будет истинно.

Продолжить

Команда Продолжить означает, что в этом месте выполнение цикла будет остановлено и передано на “новый виток” цикла, т. е. операторы, находящиеся ниже команды Продолжить, выполнены не будут.

Прервать

Прервать означает, цикл остановиться на данном шаге и работа цикла прекратиться. Выполнение программы перейдет на строчку, следующую за оператором КонецЦикла.

P.S.

Рассмотрели все виды циклов в 1с и их синтаксис. Пример применения различных видов циклы в отдельной статье: Циклы в 1с. Примеры 

Добавить комментарий

Ваш адрес email не будет опубликован.