Записки программиста 1с

get запрос в 1с

get запрос в 1с применяется для получения и передачи информации через HTTP.

Для работы с протоколом HTTP в 1С существуют три основных объекта:

  • HTTPСоединение;
  •  HTTPЗапрос;
  • HTTPОтвет.

Кроме этого для создания HTTPS-соединения используется объект ЗащищенноеСоединениеOpenSSL, а для соединения через прокси-сервер объект ИнтернетПрокси. Существует еще несколько объектов, которые могут использоваться при работе с протоколом HTTP, но используются они достаточно редко и не так важны.

HTTPСоединение

HTTPСоединение отвечает за соединение с сервером — в свойствах объекта, помимо обязательного адреса, можно указать порт, прокси, логин, пароль, таймаут, защищенное соединение и флаг аутентификации ОС, а методы повторяют основные методы HTTP.

HTTPЗапрос

HTTPЗапрос позволяет описать что именно мы хотим от сервера — в свойствах нужно обязательно указать адрес ресурса к которому мы обращаемся, кроме этого имеется возможность указать какие-либо заголовки, методы же, в свою очередь, позволяют различными способами установить и получить тело запроса.

HTTPОтвет 

HTTPОтвет является результатом выполнения запроса к серверу — из свойств мы можем узнать ответные заголовки и код состояния, а методы позволяют получить тело ответа различными способами.

&НаКлиенте
Процедура Команда1(Команда)
	// Вставить содержимое обработчика.
 Соединение = Новый HTTPСоединение("yandex.ru");
 
 Запрос = Новый HTTPЗапрос("?serya=123123");
 //В запросе можно обратиться к нужному ресурсу и с нужными параметрами
 //Запрос = Новый HTTPЗапрос("/index.php?name=Jon¶year=2"); 
 
 Ответ = Соединение.Получить(Запрос);
 
 Если Ответ.КодСостояния = 200 Тогда
 Сообщить(Ответ.ПолучитьТелоКакСтроку()); //получим HTML-код страницы 
 Иначе
 Сообщить("Код ответа: "+Ответ.КодСостояния); //анализируем код состояния и делаем выводы
 КонецЕсли;
КонецПроцедуры

Как послать защищенный https запрос к серверу из 1с

ЗащищенноеСоединениеOpenSSL используется для создания защищенного соединения OpenSSL. В этом случае есть возможность указать сертификат клиента и/или удостоверяющего центра. Чаще всего, при организации доступа к обычным сайтам по протоколу HTTPS, сертификаты указывать не требуется.

Защищенное подключение используется для соединения с сервером по протоколу  https.

get запрос в 1с

Get-запросу в языке 1С соответствует метод Получить(). Для большинства современных сайтов необходимо использовать защищенное соединение.

&НаКлиенте
Процедура ТестСоединения2(Команда)
	
	Соединение = Новый HTTPСоединение("ithelpyou.ru",443,,,,,Новый ЗащищенноеСоединениеOpenSSL());
	Запрос = Новый HTTPЗапрос("/contact/");
    Результат = Соединение.Получить(Запрос);
    Сообщить(Результат.КодСостояния);
    Сообщить(Результат.ПолучитьТелоКакСтроку());
КонецПроцедуры
get запрос в 1с

Результат выполнения кода:

get запрос в 1с

Рассмотрен get запрос в 1с.

2 комментария на “get запрос в 1с

Добавить комментарий

Ваш адрес email не будет опубликован.