Записки программиста 1с

Примитивные типы данных 1с

Примитивные типы данных 1с позволяют использовать “простые” не структурированные значения.

К примитивны типам данных в 1с относятся:

  • Число – целые или десятичные числа;
  • Строка – строковые значения ограниченной или неограниченной длины;
  • Дата-дата, время, дата+время;
  • Булево-значения Истина или Ложь;
  • Тип
  • Неопределенно
  • Null
примитивные типы данных в 1с
Примитивные типы данных 1с

Базовые типы данных являются общими и не привязаны непосредственно к объектам конфигурации.

Существуют следующие базовые типы данных:

  • числовой — любое десятичное число;
  • строковый — любая последовательность символов, в том числе и пустая;
  • дата — любая дата и время из допустимого диапазона;
  • булево — принимает одно из двух возможных значений: Истина или Ложь;
  • не определено — пустое значение, не принадлежащее ни к какому другому типу.


Базовые типы данных могут быть преобразованы друг в друга функциями преобразования.

Тип данных Число

По сравнению с другими языками программирования, в 1с не разделяются числа на дробные и целые и так далее. Все числа в 1с относятся к типу Число.

В значениях типа “Число”, имеющих дробную часть, в тексте программного целая
и дробная части разделяются точкой. Вот так: 5.25. Функции и операции работы с числами рассмотрены в статье “Математические функции 1с”.

Пример использования:

&НаКлиенте
Процедура Команда1(Команда)
//Тип данных Число	
Перем Слагаемое1;
Перем Слагаемое2;
Перем Сумма;
Слагаемое1=10;
Слагаемое2=20;
Сумма=Слагаемое1+Слагаемое2;
Сообщить("Сумма="+Сумма);
КонецПроцедуры
примитивные типы данных в 1с
Примитивный тип данных число

Тип данных Строка

Значения типа “Строка” в тексте программного модуля заключаются в двойные кавычки. Для типа Строка допускается операция сложения или конкатенации. Строковые функции также рассмотрены в отдельной статье “Строковые функции в 1с”.

&НаКлиенте
Процедура Команда2(Команда)
//Тип данных Строка	
Перем Фамилия;
Перем Имя;
Перем Отчество;
Перем Фио;
Имя="Барсик";
Фамилия="Пушковский";
Отчество="Чернышевич";
ФИО=Фамилия+Имя+Отчество;
Сообщить("ФИО="+ФИО);
КонецПроцедуры
примитивные типы данных в 1с
Примитивный тип данных строка

Тип данных Дата

Значения типа “Дата” в тексте программного модуля заключаются в одинарные кавычки. Вот так: ‘20120310’ или ‘20120310195900’. Первый пример означает 10 марта 2012 года (2012 год, 03 месяц, 10 день), второй пример — 10 марта 2012 года 19 часов 59 минут 00 секунд (2012 год, 03 месяц, 10 день, 19 час, 59 минута, 00 секунд). Функции работы с Датой частично представлены в статье: “Тип дата примеры”.

Тип данных Булево

Значения типа Булево могут принимать только два значения:

  • Истина;
  • Ложь.

В программном коде допускается использовать названия данных значений, как на русском так и на английском языках.

Тип данных Тип

Язык программирования в 1с : Предприятии не является типизированным. Это означает, что для работы с переменными и значениями не обязательно указывать тип. Этот тип применяется для проверки принадлежности переменной конкретному типу.

&НаКлиенте
Процедура Команда3(Команда)
Перем Сумма;
Перем Проверка;
Сумма=10;
Если ТипЗнч(Сумма)=Тип("Число") тогда
	Проверка=Истина;
иначе
	Проверка=Ложь;
конецесли;
Сообщить("Проверка="+Проверка);
КонецПроцедуры

Тип данных Неопределенно

Этот тип данных может принимать только одно значение “Неопределенно”. Неопределенно-это пустое значение неизвестного типа.

Тип данных Null

Тип данных Null применяется в запросах и базе данных . Он показывает, что в поле “ничего нет и не известен тип “. Значение типа Null может принимать только одно значение “Null”. В языке запросов 1с используется специальная функция проверки на Null: ЕстьNull.

Рассмотрели примитивные типы данных в 1с.

Один ответ на “Примитивные типы данных 1с

Добавить комментарий

Ваш адрес email не будет опубликован.